Ticker

6/recent/ticker-posts

Alternative Square Pattern with Solution




Alternative Square Pattern:

Problem Description:

You're given a number N. Print the first N lines of the below-given pattern.

            1 2 3 4 5

            10 9 8 7 6

            11 12 13 14 15

            20 19 18 17 16

            21 22 23 24 25

            30 29 28 27 26

Input:

·       First-line will contain the number N.

Output:

Print the first N lines of the given pattern.

Constraints

·       1≤N≤200

Sample Input 1:

            4

Sample Output 1:

            1 2 3 4 5

            10 9 8 7 6

            11 12 13 14 15

            20 19 18 17 16

Sample Input 2:

            2

Sample Output 2:

            1 2 3 4 5

            10 9 8 7 6

EXPLANATION:

·       In the first example, we'll print the first 4 lines of the given pattern.

·       In the second example, we'll print the first 2 lines of the given pattern.

Solution:

C++:

#include <iostream>
using namespace std;

int main()
{
    int nk = -4;
    cin >> n;
    for (int i = 1i <= ni++)
    {
        if (i % 2 != 0)
        {
            k += 4;
            for (int j = 1j <= 5j++)
                cout << ++k << " ";
            cout << endl;
        }
        else
        {
            k += 6;
            for (int j = 1j <= 5j++)
                cout << --k << " ";
            cout << endl;
        }
    }
    return 0;
}



Don't forget to share this post.

Post a Comment

0 Comments